CVE-2025-58756
CVE-2025-58756 · MONAI's unsafe torch usage may lead to arbitrary code execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MONAI (Medical Open Network for AI) is an AI toolkit for health care imaging. In versions up to and including 1.5.0, in `model_dict = torch.load(full_path, map_location=torch.device(device), weights_only=True)` in monai/bundle/scripts.py , `weights_only=True` is loaded securely. However, insecure loading methods still exist elsewhere in the project, such as when loading checkpoints. This is a common practice when users want to reduce training time and costs by loading pre-trained models downloaded from other platforms. Loading a checkpoint containing malicious content can trigger a deserialization vulnerability, leading to code execution. As of time of publication, no known fixed versions are available.
CVSS 8.8 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
monai
- Versions
- <= 1.5.0: Affected
No fix published
monai PyPI
- Versions
- 0.0.1
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.6.0
- 0.7.0
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.2rc1
- 1.3.3rc1
- 1.4.0
- 1.4.0rc1
- 1.4.0rc10
- 1.4.0rc11
- 1.4.0rc12
- 1.4.0rc2
- 1.4.0rc3
- 1.4.0rc4
- 1.4.0rc5
- 1.4.0rc6
- 1.4.0rc7
- 1.4.0rc8
- 1.4.0rc9
- 1.4.1rc1
- 1.5.0
- 1.5.0rc1
- Affected ranges
- ECOSYSTEM: < 1.5.1
Update to 1.5.1
monai PyPI
- Versions
- 0.0.1
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.6.0
- 0.7.0
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.2rc1
- 1.3.3rc1
- 1.4.0
- 1.4.0rc1
- 1.4.0rc10
- 1.4.0rc11
- 1.4.0rc12
- 1.4.0rc2
- 1.4.0rc3
- 1.4.0rc4
- 1.4.0rc5
- 1.4.0rc6
- 1.4.0rc7
- 1.4.0rc8
- 1.4.0rc9
- 1.4.1rc1
- 1.5.0
- 1.5.0rc1
- Affected ranges
- ECOSYSTEM: < 1.5.1rc1
Update to 1.5.1rc1