CVE-2025-58764
CVE-2025-58764 · Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.
CVSS 8.7 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
claude-code
- Versions
- < 1.0.105: Affected
No fix published
@anthropic-ai/claude-code npm
- Affected ranges
- SEMVER: < 1.0.105
Update to 1.0.105