CVE-2025-58769
CVE-2025-58769 · auth0-PHP: Improper File Type Handling in Bulk User Import
This page contains facts from public vulnerability sources. Check the original advisory before updating.
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
CVSS 3.3 · Low · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
laravel-auth0
- Versions
- >= 3.3.0, < 8.17.0: Affected
No fix published
auth0/auth0-php Packagist
- Versions
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 5.0.0
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.1.0
- 5.1.1
- 5.2.0
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 5.5.0
- 5.5.1
- 5.6.0
- 5.7.0
- 6.0.0-alpha.1
- 6.0.0-alpha.2
- 7.0.0
- 7.1.0
- 7.2.0
- 7.3.0
- 7.4.0
- 7.5.0
- 7.6.0
- 7.6.1
- 7.6.2
- 7.7.0
- 7.8.0
- 7.9.0
- 7.9.1
- 7.9.2
- 8.0.0
- 8.0.0-BETA1
- 8.0.0-BETA2
- 8.0.0-BETA3
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.10.0
- 8.11.0
- 8.11.1
- 8.12.0
- 8.13.0
- 8.14.0
- 8.15.0
- 8.16.0
- 8.2.0
- 8.2.1
- 8.3.0
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- 8.4.0
- 8.5.0
- 8.6.0
- 8.7.0
- 8.7.1
- 8.8.0
- 8.9.0
- 8.9.1
- 8.9.3
- Affected ranges
- ECOSYSTEM: ≥ 3.3.0, < 8.17.0
Update to 8.17.0
Original sources
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw
- https://github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432
- https://github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x
- https://github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c
- https://github.com/auth0/auth0-PHP/releases/tag/8.17.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-58769