p PatchFirst

CVE-2025-59041

CVE-2025-59041 · Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

CVSS 8.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

Original sources

Check your server →