p PatchFirst

CVE-2025-59417

CVE-2025-59417 · Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.

CVSS 6.8 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • lobe-chat

    Versions
    • < 1.129.4: Affected

    No fix published

  • @lobehub/chat npm

    Affected ranges
    • SEMVER: < 1.129.4

    Update to 1.129.4

Original sources

Check your server →