CVE-2025-59828
CVE-2025-59828 · Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
CVSS 7.7 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
claude-code
- Versions
- < 1.0.39: Affected
No fix published
@anthropic-ai/claude-code npm
- Affected ranges
- SEMVER: < 1.0.39
Update to 1.0.39