CVE-2025-59831
CVE-2025-59831 · `git-comiters` Command Injection vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
git-commiters is a Node.js function module providing committers stats for their git repository. Prior to version 0.1.2, there is a command injection vulnerability in git-commiters. This vulnerability manifests with the library's primary exported API: gitCommiters(options, callback) which allows specifying options such as cwd for current working directory and revisionRange as a revision pointer, such as HEAD. However, the library does not sanitize for user input or practice secure process execution API to separate commands from their arguments and as such, uncontrolled user input is concatenated into command execution. This issue has been patched in version 0.1.2.
CVSS 8.7 · High · EPSS 4.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
git-commiters.js
- Versions
- < 0.1.2: Affected
No fix published
git-commiters npm
- Affected ranges
- SEMVER: < 0.1.2
Update to 0.1.2