CVE-2025-6019
CVE-2025-6019 · Libblockdev: lpe from allow_active to root in libblockdev via udisks
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
A Local Privilege Escalation (LPE) vulnerability was found in libblockdev. Generally, the "allow_active" setting in Polkit permits a physically present user to take certain actions based on the session type. Due to the way libblockdev interacts with the udisks daemon, an "allow_active" user on a system may be able escalate to full root privileges on the target host. Normally, udisks mounts user-provided filesystem images with security flags like nosuid and nodev to prevent privilege escalation. However, a local attacker can create a specially crafted XFS image containing a SUID-root shell, then trick udisks into resizing it. This mounts their malicious filesystem with root privileges, allowing them to execute their SUID-root shell and gain complete control of the system.
CVSS 7.0 · High · EPSS 0.5% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 10
- Versions
- ≥ 0:3.2.0-4.el10_0: Not affected (rpm)
No fix published
red hat enterprise linux 7 extended lifecycle support
- Versions
- ≥ 0:2.18-5.el7_9.1: Not affected (rpm)
No fix published
red hat enterprise linux 8
- Versions
- ≥ 0:2.28-7.el8_10: Not affected (rpm)
No fix published
red hat enterprise linux 8.2 advanced update support
- Versions
- ≥ 0:2.19-13.el8_2: Not affected (rpm)
No fix published
red hat enterprise linux 8.4 advanced mission critical update support
- Versions
- ≥ 0:2.24-6.el8_4: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 advanced mission critical update support
- Versions
- ≥ 0:2.24-9.el8_6: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 telecommunications update service
- Versions
- ≥ 0:2.24-9.el8_6: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 update services for sap solutions
- Versions
- ≥ 0:2.24-9.el8_6: Not affected (rpm)
No fix published
red hat enterprise linux 8.8 update services for sap solutions
- Versions
- ≥ 0:2.28-3.el8_8: Not affected (rpm)
No fix published
red hat enterprise linux 9
- Versions
- ≥ 0:2.28-14.el9_6: Not affected (rpm)
No fix published
red hat enterprise linux 9.0 update services for sap solutions
- Versions
- ≥ 0:2.25-12.el9_0: Not affected (rpm)
No fix published
red hat enterprise linux 9.2 update services for sap solutions
- Versions
- ≥ 0:2.28-5.el9_2: Not affected (rpm)
No fix published
red hat enterprise linux 9.4 extended update support
- Versions
- ≥ 0:2.28-11.el9_4: Not affected (rpm)
No fix published
libblockdev Debian:12
- Versions
- 2.28-2
- Affected ranges
- ECOSYSTEM: < 2.28-2+deb12u1
Update to 2.28-2+deb12u1
libblockdev Debian:13
- Affected ranges
- ECOSYSTEM: < 3.3.0-2.1
Update to 3.3.0-2.1
libblockdev Debian:14
- Affected ranges
- ECOSYSTEM: < 3.3.0-2.1
Update to 3.3.0-2.1
libblockdev Ubuntu:Pro:18.04:LTS
- Versions
- 2.12-2
- 2.12-3
- 2.14-2
- 2.14-3
- 2.16-2
- Affected ranges
- ECOSYSTEM: < 2.16-2ubuntu0.1~esm1
Update to 2.16-2ubuntu0.1~esm1
udisks2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.6.5-2ubuntu2
- 2.6.5-2ubuntu3
- 2.7.6-2ubuntu4
- 2.7.6-2ubuntu6
- 2.7.6-3
- 2.7.6-3ubuntu0.1
- 2.7.6-3ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 2.7.6-3ubuntu0.2+esm1
Update to 2.7.6-3ubuntu0.2+esm1
libblockdev Ubuntu:Pro:20.04:LTS
- Versions
- 2.22-1
- 2.23-2
- 2.23-2ubuntu2
- 2.23-2ubuntu3
- Affected ranges
- ECOSYSTEM: < 2.23-2ubuntu3+esm1
Update to 2.23-2ubuntu3+esm1
udisks2 Ubuntu:Pro:20.04:LTS
- Versions
- 2.8.4-1
- 2.8.4-1build1
- 2.8.4-1ubuntu1
- 2.8.4-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.8.4-1ubuntu2+esm1
Update to 2.8.4-1ubuntu2+esm1
libblockdev Ubuntu:22.04:LTS
- Versions
- 2.25-2build1
- 2.26-1
- Affected ranges
- ECOSYSTEM: < 2.26-1ubuntu0.1
Update to 2.26-1ubuntu0.1
udisks2 Ubuntu:22.04:LTS
- Versions
- 2.9.4-1
- 2.9.4-1build1
- 2.9.4-1ubuntu1
- 2.9.4-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.9.4-1ubuntu2.2
Update to 2.9.4-1ubuntu2.2
libblockdev Ubuntu:24.04:LTS
- Versions
- 3.0.3-1
- 3.0.4-1
- 3.1.0-1
- 3.1.0-1build1
- 3.1.1-1
- Affected ranges
- ECOSYSTEM: < 3.1.1-1ubuntu0.1
Update to 3.1.1-1ubuntu0.1
udisks2 Ubuntu:24.04:LTS
- Versions
- 2.10.1-1ubuntu1
- 2.10.1-1ubuntu2
- 2.10.1-6
- 2.10.1-6build1
- 2.10.1-6ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.10.1-6ubuntu1.2
Update to 2.10.1-6ubuntu1.2
Original sources
- https://access.redhat.com/errata/RHSA-2025:10796
- https://access.redhat.com/errata/RHSA-2025:9320
- https://access.redhat.com/errata/RHSA-2025:9321
- https://access.redhat.com/errata/RHSA-2025:9322
- https://access.redhat.com/errata/RHSA-2025:9323
- https://access.redhat.com/errata/RHSA-2025:9324
- https://access.redhat.com/errata/RHSA-2025:9325
- https://access.redhat.com/errata/RHSA-2025:9326
- https://access.redhat.com/errata/RHSA-2025:9327
- https://access.redhat.com/errata/RHSA-2025:9328
- https://access.redhat.com/errata/RHSA-2025:9878
- https://access.redhat.com/security/cve/CVE-2025-6019
- https://bugzilla.redhat.com/show_bug.cgi?id=2370051
- https://cdn2.qualys.com/2025/06/17/suse15-pam-udisks-lpe.txt
- http://www.openwall.com/lists/oss-security/2025/06/17/5
- http://www.openwall.com/lists/oss-security/2025/06/17/6
- https://lists.debian.org/debian-lts-announce/2025/06/msg00018.html
- http://www.openwall.com/lists/oss-security/2025/06/18/1
- https://www.bleepingcomputer.com/news/linux/new-linux-udisks-flaw-lets-attackers-get-root-on-major-linux-distros/
- https://news.ycombinator.com/item?id=44325861
- https://nvd.nist.gov/vuln/detail/CVE-2025-6019