CVE-2025-6035
CVE-2025-6035 · Gimp: gimp integer overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in GIMP. An integer overflow vulnerability exists in the GIMP "Despeckle" plug-in. The issue occurs due to unchecked multiplication of image dimensions, such as width, height, and bytes-per-pixel (img_bpp), which can result in allocating insufficient memory and subsequently performing out-of-bounds writes. This issue could lead to heap corruption, a potential denial of service (DoS), or arbitrary code execution in certain scenarios.
CVSS 6.1 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
red hat enterprise linux 8
No fix published
red hat enterprise linux 9
No fix published
gimp Debian:12
- Versions
- 2.10.34-1
- 2.10.34-1+deb12u1
- 2.10.34-1+deb12u2
- 2.10.34-1+deb12u3
- Affected ranges
- ECOSYSTEM: < 2.10.34-1+deb12u4
Update to 2.10.34-1+deb12u4
gimp Debian:13
- Affected ranges
- ECOSYSTEM: < 3.0.4-2
Update to 3.0.4-2
gimp Debian:14
- Affected ranges
- ECOSYSTEM: < 3.0.4-2
Update to 3.0.4-2
gimp Ubuntu:Pro:16.04:LTS
- Versions
- 2.8.14-1ubuntu2
- 2.8.14-1.2ubuntu1
- 2.8.16-1ubuntu1
- 2.8.16-1ubuntu1.1
- 2.8.16-1ubuntu1.1+esm1
- 2.8.16-1ubuntu1.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.8.16-1ubuntu1.1+esm3
Update to 2.8.16-1ubuntu1.1+esm3
gimp Ubuntu:Pro:18.04:LTS
- Versions
- 2.8.20-1
- 2.8.20-1.1
- 2.8.20-2
- 2.8.22-1
- 2.8.22-1ubuntu0.1~esm1
- 2.8.22-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: < 2.8.22-1ubuntu0.1~esm3
Update to 2.8.22-1ubuntu0.1~esm3
gimp Ubuntu:Pro:20.04:LTS
- Versions
- 2.10.8-2
- 2.10.14-2
- 2.10.14-2build1
- 2.10.14-2ubuntu1
- 2.10.14-3
- 2.10.18-1
- 2.10.18-1ubuntu0.1
- 2.10.18-1ubuntu0.1+esm1
- 2.10.18-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.10.18-1ubuntu0.1+esm3
Update to 2.10.18-1ubuntu0.1+esm3
gimp Ubuntu:Pro:22.04:LTS
- Versions
- 2.10.24-2
- 2.10.28-1
- 2.10.30-1
- 2.10.30-1build1
- 2.10.30-1ubuntu0.1
- 2.10.30-1ubuntu0.1+esm1
- 2.10.30-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.10.30-1ubuntu0.1+esm3
Update to 2.10.30-1ubuntu0.1+esm3
gimp Ubuntu:Pro:24.04:LTS
- Versions
- 2.10.34-1
- 2.10.36-1
- 2.10.36-2
- 2.10.36-3build2
- 2.10.36-3build3
- 2.10.36-3ubuntu0.24.04.1
- 2.10.36-3ubuntu0.24.04.1+esm1
- 2.10.36-3ubuntu0.24.04.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.10.36-3ubuntu0.24.04.1+esm3
Update to 2.10.36-3ubuntu0.24.04.1+esm3