p PatchFirst

CVE-2025-6186

CVE-2025-6186 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to achieve account takeover by injecting malicious HTML into work item names.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 18.1, < 18.1.4: Affected (semver)
    • ≥ 18.2, < 18.2.2: Affected (semver)

    Update to 18.1.4; Update to 18.2.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →