CVE-2025-6237
CVE-2025-6237 · Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.
CVSS 9.8 · Critical · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
invoke-ai/invokeai
- Versions
- ≥ unspecified, ≤ latest: Affected (custom)
No fix published
invokeai PyPI
- Versions
- 2.2.4.5
- 2.2.4.6
- 2.2.4.7
- 2.2.5
- 2.3.0
- 2.3.0a0
- 2.3.0a1
- 2.3.0a2
- 2.3.0a3
- 2.3.0rc3
- 2.3.0rc4
- 2.3.0rc5
- 2.3.0rc6
- 2.3.0rc7
- 2.3.1
- 2.3.1.post1
- 2.3.1.post2
- 2.3.1rc4
- 2.3.2
- 2.3.2.post1
- 2.3.3
- 2.3.3rc1
- 2.3.4
- 2.3.4.post1
- 2.3.4a0
- 2.3.4rc1
- 2.3.5
- 2.3.5.post1
- 2.3.5.post2
- 2.3.5rc1
- 3.0.0
- 3.0.1
- 3.0.1.post1
- 3.0.1.post2
- 3.0.1.post3
- 3.0.1rc1
- 3.0.1rc2
- 3.0.2
- 3.0.2.post1
- 3.0.2a1
- 3.0.2rc1
- 3.1.0
- 3.1.1
- 3.1.1rc1
- 3.2.0
- 3.3.0
- 3.3.0.post1
- 3.3.0.post2
- 3.3.0.post3
- 3.4.0
- 3.4.0.post1
- 3.4.0.post2
- 3.4.0rc2
- 3.4.0rc3
- 3.4.0rc4
- 3.5.0
- 3.5.0rc1
- 3.5.0rc2
- 3.5.0rc3
- 3.5.1
- 3.6.0
- 3.6.0rc1
- 3.6.0rc2
- 3.6.0rc3
- 3.6.0rc4
- 3.6.0rc5
- 3.6.0rc6
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.3rc1
- 3.7.0
- 4.0.0
- 4.0.0rc1
- 4.0.0rc2
- 4.0.0rc4
- 4.0.0rc5
- 4.0.0rc6
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.1.0
- 4.2.0
- 4.2.0a1
- 4.2.0a2
- 4.2.0a3
- 4.2.0a4
- 4.2.0b1
- 4.2.0b2
- 4.2.1
- 4.2.2
- 4.2.2.post1
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.6.post1
- 4.2.6a1
- 4.2.6rc1
- 4.2.7
- 4.2.7.post1
- 4.2.7rc1
- 4.2.8
- 4.2.8rc1
- 4.2.8rc2
- 4.2.9
- 4.2.9.dev10
- 4.2.9.dev11
- 4.2.9.dev12
- 4.2.9.dev20240823
- 4.2.9.dev20240824
- 4.2.9.dev3
- 4.2.9.dev4
- 4.2.9.dev5
- 4.2.9.dev6
- 4.2.9.dev7
- 4.2.9.dev8
- 4.2.9.dev9
- 4.2.9rc1
- 4.2.9rc2
- 5.0.0
- 5.0.0.dev13
- 5.0.0a1
- 5.0.0a2
- 5.0.0a3
- 5.0.0a4
- 5.0.0a5
- 5.0.0a6
- 5.0.0a7
- 5.0.0a8
- 5.0.0rc1
- 5.0.0rc2
- 5.0.1
- 5.0.2
- 5.1.0
- 5.1.0rc1
- 5.1.0rc2
- 5.1.0rc3
- 5.1.0rc4
- 5.1.0rc5
- 5.1.1
- 5.10.0
- 5.10.0.dev1
- 5.10.0.dev2
- 5.10.0.dev3
- 5.10.0.dev4
- 5.10.0a1
- 5.10.0rc1
- 5.10.1
- 5.11.0
- 5.11.0rc1
- 5.11.0rc2
- 5.12.0
- 5.12.0rc1
- 5.12.0rc2
- 5.13.0
- 5.13.0rc1
- 5.13.0rc2
- 5.13.0rc3
- 5.14.0
- 5.15.0
- 5.2.0
- 5.2.0rc1
- 5.2.0rc2
- 5.3.0
- 5.3.0rc1
- 5.3.0rc2
- 5.3.1
- 5.3.1rc1
- 5.4.0
- 5.4.1
- 5.4.1rc1
- 5.4.1rc2
- 5.4.2
- 5.4.2rc1
- 5.4.3
- 5.4.3rc1
- 5.4.3rc2
- 5.4.4rc1
- 5.5.0
- 5.5.0rc1
- 5.6.0
- 5.6.0rc1
- 5.6.0rc2
- 5.6.0rc3
- 5.6.0rc4
- 5.6.1
- 5.6.1rc1
- 5.6.2
- 5.7.0
- 5.7.0a1
- 5.7.0rc1
- 5.7.0rc2
- 5.7.1
- 5.7.2
- 5.7.2rc1
- 5.7.2rc2
- 5.8.0
- 5.8.0a1
- 5.8.0a2
- 5.8.0rc1
- 5.8.1
- 5.9.0
- 5.9.0rc1
- 5.9.0rc2
- 5.9.1
- 6.0.0
- 6.0.0a1
- 6.0.0a10
- 6.0.0a2
- 6.0.0a3
- 6.0.0a4
- 6.0.0a5
- 6.0.0a6
- 6.0.0a8
- 6.0.0rc1
- 6.0.0rc2
- 6.0.0rc3
- 6.0.0rc4
- 6.0.0rc5
- 6.0.1
- 6.0.1rc1
- 6.0.2
- 6.1.0
- 6.1.0rc1
- 6.1.0rc2
- 6.2.0
- 6.3.0
- 6.3.0a1
- 6.3.0rc1
- 6.3.0rc2
- 6.4.0
- 6.4.0rc1
- 6.4.0rc2
- 6.5.0
- 6.5.0rc1
- 6.5.1
- 6.6.0
- 6.6.0rc1
- 6.6.0rc2
- 6.7.0rc1
- Affected ranges
- ECOSYSTEM: < 6.7.0
Update to 6.7.0