p PatchFirst

CVE-2025-62393

CVE-2025-62393 · Moodle: course access permissions not properly checked in course_output_fragment_course_overview

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the course overview output function where user access permissions were not fully enforced. This could allow unauthorized users to view information about courses they should not have access to, potentially exposing limited course details.

CVSS 4.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle/moodle Packagist

    Versions
    • v5.0.0
    • v5.0.0-beta
    • v5.0.0-rc1
    • v5.0.0-rc2
    • v5.0.0-rc3
    • v5.0.1
    • v5.0.2
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0-beta, < 5.0.3

    Update to 5.0.3

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →