CVE-2025-62697
CVE-2025-62697 · Improperly sanitized style parameter in LanguageSelector
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in The Wikimedia Foundation Mediawiki - LanguageSelector Extension allows Code Injection.This issue affects Mediawiki - LanguageSelector Extension: from master before 1.39.
CVSS 8.8 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mediawiki - languageselector extension
- Versions
- ≥ master, < 1.39: Affected (semver)
Update to 1.39
mediawiki Ubuntu:18.04:LTS
- Versions
- 1:1.27.3-1
- 1:1.27.4-1
- 1:1.27.4-2
- 1:1.27.4-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:Pro:20.04:LTS
- Versions
- 1:1.31.2-1ubuntu1
- 1:1.31.5-1
- 1:1.31.5-1ubuntu1
- 1:1.31.5-2
- 1:1.31.5-3
- 1:1.31.5-3ubuntu1
- 1:1.31.6-1
- 1:1.31.7-1
- 1:1.31.7-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:Pro:22.04:LTS
- Versions
- 1:1.35.3-1
- 1:1.35.4-1
- 1:1.35.5-1
- 1:1.35.5-1ubuntu1
- 1:1.35.5-1ubuntu2
- 1:1.35.5-1ubuntu3
- 1:1.35.6-1
- 1:1.35.6-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:Pro:24.04:LTS
- Versions
- 1:1.39.4-2
- 1:1.39.5-1
- 1:1.39.6-1
- 1:1.39.7-1
- 1:1.39.7-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:25.10
- Versions
- 1:1.43.1+dfsg-1
- 1:1.43.1+dfsg-2
- 1:1.43.3+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:26.10
- Versions
- 1:1.43.8+dfsg-2
- 1:1.43.9+dfsg-1
- 1:1.43.9+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mediawiki Ubuntu:26.04:LTS
- Versions
- 1:1.43.3+dfsg-1
- 1:1.43.5+dfsg-1
- 1:1.43.6+dfsg-2
- 1:1.43.8+dfsg-1
- 1:1.43.8+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published