p PatchFirst

CVE-2025-64181

CVE-2025-64181 · OpenEXR Makes Use of Uninitialized Memory

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.3.0 through 3.3.5 and 3.4.0 through 3.4.2, while fuzzing `openexr_exrcheck_fuzzer`, Valgrind reports a conditional branch depending on uninitialized data inside `generic_unpack`. This indicates a use of uninitialized memory. The issue can result in undefined behavior and/or a potential crash/denial of service. Versions 3.3.6 and 3.4.3 fix the issue.

CVSS 2.0 · Low · EPSS 0.4% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • openexr

    Versions
    • >= 3.3.0, < 3.3.6: Affected
    • >= 3.4.0, < 3.4.3: Affected

    No fix published

  • openexr Debian:12

    Versions
    • 3.1.13-1
    • 3.1.13-2
    • 3.1.5-5
    • 3.1.5-5.1
    • 3.1.5-5.1+hurd.1
    • 3.4.14-0.1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • openexr Debian:13

    Versions
    • 3.1.13-2
    • 3.4.14-0.1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • openexr Debian:14

    Versions
    • 3.1.13-2
    Affected ranges
    • ECOSYSTEM: < 3.4.6+ds-1

    Update to 3.4.6+ds-1

  • openexr PyPI

    Versions
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    Affected ranges
    • ECOSYSTEM: ≥ 3.3.0, < 3.3.6

    Update to 3.3.6

  • openexr PyPI

    Versions
    • 3.4.0
    • 3.4.1
    • 3.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0, < 3.4.3

    Update to 3.4.3

  • openexr PyPI

    Versions
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.4.0
    • 3.4.1
    • 3.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 3.3.0, < 3.3.6 ∪ ≥ 3.4.0, < 3.4.3

    Update to 3.3.6; Update to 3.4.3

Original sources

Check your server →