p PatchFirst

CVE-2025-64720

CVE-2025-64720 · LIBPNG is vulnerable to a buffer overflow in `png_image_read_composite` via incorrect palette premultiplication

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.

CVSS 7.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libpng

    Versions
    • >= 1.6.0, < 1.6.51: Affected

    No fix published

  • libpng1.6 Debian:12

    Versions
    • 1.6.39-2
    Affected ranges
    • ECOSYSTEM: < 1.6.39-2+deb12u1

    Update to 1.6.39-2+deb12u1

  • libpng1.6 Debian:13

    Versions
    • 1.6.48-1
    Affected ranges
    • ECOSYSTEM: < 1.6.48-1+deb13u1

    Update to 1.6.48-1+deb13u1

  • libpng1.6 Debian:14

    Versions
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1
    • 1.6.50-1~exp1
    Affected ranges
    • ECOSYSTEM: < 1.6.51-1

    Update to 1.6.51-1

  • libpng1.6 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.20-2
    • 1.6.20-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm2

    Update to 1.6.20-2ubuntu0.1~esm2

  • libpng1.6 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.6.34-1
    • 1.6.34-1ubuntu0.18.04.1
    • 1.6.34-1ubuntu0.18.04.2
    Affected ranges
    • ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm1

    Update to 1.6.34-1ubuntu0.18.04.2+esm1

  • libpng1.6 Ubuntu:Pro:20.04:LTS

    Versions
    • 1.6.37-1
    • 1.6.37-2
    Affected ranges
    • ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm1

    Update to 1.6.37-2ubuntu0.1~esm1

  • libpng1.6 Ubuntu:22.04:LTS

    Versions
    • 1.6.37-3build4
    • 1.6.37-3build5
    Affected ranges
    • ECOSYSTEM: < 1.6.37-3ubuntu0.1

    Update to 1.6.37-3ubuntu0.1

  • libpng1.6 Ubuntu:24.04:LTS

    Versions
    • 1.6.40-1
    • 1.6.40-2
    • 1.6.40-3
    • 1.6.42-1
    • 1.6.43-1
    • 1.6.43-3
    • 1.6.43-5build1
    Affected ranges
    • ECOSYSTEM: < 1.6.43-5ubuntu0.1

    Update to 1.6.43-5ubuntu0.1

  • libpng1.6 Ubuntu:25.10

    Versions
    • 1.6.47-1.1
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1~exp1
    • 1.6.50-1
    Affected ranges
    • ECOSYSTEM: < 1.6.50-1ubuntu0.1

    Update to 1.6.50-1ubuntu0.1

Original sources

Check your server →