CVE-2025-66404
CVE-2025-66404 · mcp-server-kubernetes potential security issue in exec_in_pod tool
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. Prior to 2.9.8, there is a security issue exists in the exec_in_pod tool of the mcp-server-kubernetes MCP Server. The tool accepts user-provided commands in both array and string formats. When a string format is provided, it is passed directly to shell interpretation (sh -c) without input validation, allowing shell metacharacters to be interpreted. This vulnerability can be exploited through direct command injection or indirect prompt injection attacks, where AI agents may execute commands without explicit user intent. This vulnerability is fixed in 2.9.8.
CVSS 6.4 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
mcp-server-kubernetes
- Versions
- < 2.9.8: Affected
No fix published
mcp-server-kubernetes npm
- Affected ranges
- SEMVER: < 2.9.8
Update to 2.9.8