p PatchFirst

CVE-2025-6709

CVE-2025-6709 · Pre-Authentication Denial of Service Vulnerability in MongoDB Server's OIDC Authentication

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.

CVSS 7.5 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongodb server

    Versions
    • ≥ 7.0, < 7.0.17: Affected (custom)
    • ≥ 8.0, < 8.0.5: Affected (custom)
    • ≥ 6.0, < 6.0.21: Affected (custom)

    Update to 6.0.21; Update to 7.0.17; Update to 8.0.5

  • mongodb Ubuntu:Pro:14.04:LTS

    Versions
    • 1:2.4.6-0ubuntu5
    • 1:2.4.6-0ubuntu6
    • 1:2.4.8-1ubuntu1
    • 1:2.4.8-2
    • 1:2.4.9-1
    • 1:2.4.9-1ubuntu1
    • 1:2.4.9-1ubuntu2
    • 1:2.4.9-1ubuntu2+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:16.04:LTS

    Versions
    • 1:2.6.10-0ubuntu1
    • 1:2.6.10-0ubuntu1+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:18.04:LTS

    Versions
    • 1:3.4.7-1
    • 1:3.4.7-1ubuntu1
    • 1:3.4.7-1ubuntu2
    • 1:3.4.7-1ubuntu4
    • 1:3.4.14-3ubuntu1
    • 1:3.4.14-3ubuntu2
    • 1:3.6.3-0ubuntu1
    • 1:3.6.3-0ubuntu1.1
    • 1:3.6.3-0ubuntu1.3
    • 1:3.6.3-0ubuntu1.4
    • 1:3.6.3-0ubuntu1.4+esm1
    • 1:3.6.3-0ubuntu1.4+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:20.04:LTS

    Versions
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →