CVE-2025-67735
CVE-2025-67735 · Netty has a CRLF Injection vulnerability in io.netty.handler.codec.http.HttpRequestEncoder
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.
CVSS 6.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
netty
- Versions
- >= 4.2.0.Alpha1, < 4.2.8.Final: Affected
- < 4.1.129.Final: Affected
No fix published
netty Debian:12
- Versions
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Update to 1:4.1.48-7+deb12u2
netty Debian:13
- Versions
- 1:4.1.48-10
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Update to 1:4.1.48-10+deb13u1
netty Debian:14
- Versions
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-16
Update to 1:4.1.48-16
netty Ubuntu:Pro:14.04:LTS
- Versions
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:Pro:16.04:LTS
- Versions
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm5
Update to 1:4.0.34-1ubuntu0.1~esm5
netty Ubuntu:Pro:18.04:LTS
- Versions
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- 1:4.1.7-4ubuntu0.1+esm5
- 1:4.1.7-4ubuntu0.1+esm6
- Affected ranges
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm7
Update to 1:4.1.7-4ubuntu0.1+esm7
netty Ubuntu:Pro:20.04:LTS
- Versions
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- 1:4.1.45-1ubuntu0.1~esm4
- 1:4.1.45-1ubuntu0.1~esm6
- Affected ranges
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm7
Update to 1:4.1.45-1ubuntu0.1~esm7
netty Ubuntu:22.04:LTS
- Versions
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.2
Update to 1:4.1.48-4+deb11u2ubuntu0.2
netty Ubuntu:Pro:22.04:LTS
- Versions
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm2
- 1:4.1.48-4+deb11u2ubuntu0.1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm3
- 1:4.1.48-4+deb11u2ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.2+esm1
Update to 1:4.1.48-4+deb11u2ubuntu0.2+esm1
netty Ubuntu:24.04:LTS
- Versions
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.2
Update to 1:4.1.48-9ubuntu0.2
netty Ubuntu:Pro:24.04:LTS
- Versions
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1~esm1
- 1:4.1.48-9ubuntu0.1~esm2
- 1:4.1.48-9ubuntu0.1
- 1:4.1.48-9ubuntu0.1+esm1
- 1:4.1.48-9ubuntu0.1+esm3
- 1:4.1.48-9ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.2+esm1
Update to 1:4.1.48-9ubuntu0.2+esm1
netty Ubuntu:25.10
- Versions
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- 1:4.1.48-10ubuntu0.25.10.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:26.10
- Versions
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published