CVE-2025-68115
CVE-2025-68115 · Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.
CVSS 5.3 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
parse-server
- Versions
- < 8.6.1: Affected
- >= 9.0.0, < 9.1.0-alpha.3: Affected
No fix published
parse-server npm
- Affected ranges
- SEMVER: < 8.6.1
Update to 8.6.1
parse-server npm
- Affected ranges
- SEMVER: ≥ 9.0.0, < 9.1.0-alpha.3
Update to 9.1.0-alpha.3