CVE-2025-68619
CVE-2025-68619 · Signal K Server Vulnerable to Remote Code Execution via Malicious npm Package
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Signal K Server is a server application that runs on a central hub in a boat. Versions prior to 2.19.0 of the appstore interface allow administrators to install npm packages through a REST API endpoint. While the endpoint validates that the package name exists in the npm registry as a known plugin or webapp, the version parameter accepts arbitrary npm version specifiers including URLs. npm supports installing packages from git repositories, GitHub shorthand syntax, and HTTP/HTTPS URLs pointing to tarballs. When npm installs a package, it can automatically execute any `postinstall` script defined in `package.json`, enabling arbitrary code execution. The vulnerability exists because npm's version specifier syntax is extremely flexible, and the SignalK code passes the version parameter directly to npm without sanitization. An attacker with admin access can install a package from an attacker-controlled source containing a malicious `postinstall` script. Version 2.19.0 contains a patch for the issue.
CVSS 7.3 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
signalk-server
- Versions
- < 2.19.0: Affected
No fix published
signalk-server npm
- Affected ranges
- SEMVER: < 2.9.0
Update to 2.9.0