CVE-2025-68973
CVE-2025-68973
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In GnuPG before 2.4.9, armor_filter in g10/armor.c has two increments of an index variable where one is intended, leading to an out-of-bounds write for crafted input. (For ExtendedLTS, 2.2.51 and later are fixed versions.)
CVSS 7.8 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gnupg
- Versions
- ≥ 0, < 2.2.51: Affected (semver)
- ≥ 2.3.0, < 2.4.9: Affected (semver)
Update to 2.2.51; Update to 2.4.9
gnupg2 Debian:12
- Versions
- 2.2.40-1.1
- 2.2.40-1.1+deb12u1
- Affected ranges
- ECOSYSTEM: < 2.2.40-1.1+deb12u2
Update to 2.2.40-1.1+deb12u2
gnupg2 Debian:13
- Versions
- 2.4.7-21
- Affected ranges
- ECOSYSTEM: < 2.4.7-21+deb13u1
Update to 2.4.7-21+deb13u1
gnupg2 Debian:14
- Versions
- 2.4.7-21
- 2.4.8-1
- 2.4.8-2
- 2.4.8-3
- 2.4.8-4
- Affected ranges
- ECOSYSTEM: < 2.4.8-5
Update to 2.4.8-5
gnupg Ubuntu:Pro:14.04:LTS
- Versions
- 1.4.14-1ubuntu2
- 1.4.15-1.1ubuntu1
- 1.4.15-1.1ubuntu2
- 1.4.15-2ubuntu1
- 1.4.16-1ubuntu1
- 1.4.16-1ubuntu2
- 1.4.16-1ubuntu2.1
- 1.4.16-1ubuntu2.3
- 1.4.16-1ubuntu2.4
- 1.4.16-1ubuntu2.5
- 1.4.16-1ubuntu2.6
- 1.4.16-1ubuntu2.6+esm1
- Affected ranges
- ECOSYSTEM: < 1.4.16-1ubuntu2.6+esm2
Update to 1.4.16-1ubuntu2.6+esm2
gnupg Ubuntu:Pro:16.04:LTS
- Versions
- 1.4.18-7ubuntu1
- 1.4.19-6ubuntu1
- 1.4.20-1ubuntu1
- 1.4.20-1ubuntu2
- 1.4.20-1ubuntu3
- 1.4.20-1ubuntu3.1
- 1.4.20-1ubuntu3.2
- 1.4.20-1ubuntu3.3
- 1.4.20-1ubuntu3.3+esm2
- Affected ranges
- ECOSYSTEM: < 1.4.20-1ubuntu3.3+esm3
Update to 1.4.20-1ubuntu3.3+esm3
gnupg2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.0.28-3ubuntu1
- 2.0.28-3ubuntu2
- 2.1.11-6ubuntu1
- 2.1.11-6ubuntu2
- 2.1.11-6ubuntu2.1
- 2.1.11-6ubuntu2.1+esm1
- 2.1.11-6ubuntu2.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.1.11-6ubuntu2.1+esm3
Update to 2.1.11-6ubuntu2.1+esm3
gnupg2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.1.15-1ubuntu8
- 2.2.4-1ubuntu1
- 2.2.4-1ubuntu1.1
- 2.2.4-1ubuntu1.2
- 2.2.4-1ubuntu1.3
- 2.2.4-1ubuntu1.4
- 2.2.4-1ubuntu1.5
- 2.2.4-1ubuntu1.6
- 2.2.4-1ubuntu1.6+esm1
- Affected ranges
- ECOSYSTEM: < 2.2.4-1ubuntu1.6+esm2
Update to 2.2.4-1ubuntu1.6+esm2
gnupg2 Ubuntu:Pro:20.04:LTS
- Versions
- 2.2.12-1ubuntu3
- 2.2.17-3ubuntu1
- 2.2.19-3ubuntu2
- 2.2.19-3ubuntu2.1
- 2.2.19-3ubuntu2.2
- 2.2.19-3ubuntu2.4
- 2.2.19-3ubuntu2.5
- Affected ranges
- ECOSYSTEM: < 2.2.19-3ubuntu2.5+esm1
Update to 2.2.19-3ubuntu2.5+esm1
gnupg2 Ubuntu:22.04:LTS
- Versions
- 2.2.20-1ubuntu4
- 2.2.27-2ubuntu1
- 2.2.27-3ubuntu1
- 2.2.27-3ubuntu2
- 2.2.27-3ubuntu2.1
- 2.2.27-3ubuntu2.3
- 2.2.27-3ubuntu2.4
- Affected ranges
- ECOSYSTEM: < 2.2.27-3ubuntu2.5
Update to 2.2.27-3ubuntu2.5
gnupg2 Ubuntu:24.04:LTS
- Versions
- 2.2.40-1.1ubuntu1
- 2.4.4-2ubuntu7
- 2.4.4-2ubuntu15
- 2.4.4-2ubuntu16
- 2.4.4-2ubuntu17
- 2.4.4-2ubuntu17.2
- 2.4.4-2ubuntu17.3
- Affected ranges
- ECOSYSTEM: < 2.4.4-2ubuntu17.4
Update to 2.4.4-2ubuntu17.4
gnupg2 Ubuntu:25.10
- Versions
- 2.4.4-2ubuntu23
- 2.4.4-2ubuntu24
- 2.4.7-17ubuntu3
- 2.4.8-2ubuntu1
- 2.4.8-2ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.4.8-2ubuntu2.1
Update to 2.4.8-2ubuntu2.1
Original sources
- https://gpg.fail/memcpy
- https://news.ycombinator.com/item?id=46403200
- https://www.openwall.com/lists/oss-security/2025/12/28/5
- https://github.com/gpg/gnupg/commit/115d138ba599328005c5321c0ef9f00355838ca9
- https://github.com/gpg/gnupg/blob/ff30683418695f5d2cc9e6cf8c9418e09378ebe4/g10/armor.c#L1305-L1306
- https://github.com/gpg/gnupg/compare/gnupg-2.2.50...gnupg-2.2.51
- https://media.ccc.de/v/39c3-to-sign-or-not-to-sign-practical-vulnerabilities-i
- http://www.openwall.com/lists/oss-security/2025/12/29/11
- https://lists.debian.org/debian-lts-announce/2026/01/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-68973