CVE-2025-69210
CVE-2025-69210 · FacturaScripts vulnerable to Stored Cross-Site Scripting (XSS) via XML File Upload
This page contains facts from public vulnerability sources. Check the original advisory before updating.
FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.7, a stored cross-site scripting (XSS) vulnerability exists in the product file upload functionality. Authenticated users can upload crafted XML files containing executable JavaScript. These files are later rendered by the application without sufficient sanitization or content-type enforcement, allowing arbitrary JavaScript execution when the file is accessed. Because product files uploaded by regular users are visible to administrative users, this vulnerability can be leveraged to execute malicious JavaScript in an administrator’s browser session. Version 2025.7 fixes the issue.
CVSS 1.2 · Low · EPSS 1.0% · Public exploit · Fix available
- Published
- Updated
Stack: php
Affected products and versions
facturascripts
- Versions
- < 2025.7: Affected
No fix published
facturascripts/facturascripts Packagist
- Versions
- 2018.03
- 2018.04
- 2018.05
- 2018.11
- v2018.12
- v2018.13
- v2018.14
- v2018.15
- v2018.16
- v2020.01
- v2020.2
- v2020.3
- v2020.4
- v2020.51
- v2020.61
- v2020.71
- v2020.80
- v2021
- v2021.1
- v2021.2
- v2021.4
- v2021.51
- v2021.71
- v2021.81
- v2022.06
- v2022.08
- v2022.2
- v2022.4
- v2022.51
- v2023.03
- v2023.08
- v2023.16
- v2023.21
- v2024
- v2024.1
- v2024.2
- v2024.3
- v2024.5
- v2024.7
- v2024.8
- v2024.9
- v2024.91
- v2024.93
- v2024.94
- v2024.95
- v2024.96
- v2025
- v2025.2
- v2025.3
- v2025.4
- Affected ranges
- ECOSYSTEM: < 2025.7
Update to 2025.7
facturascripts/facturascripts Packagist
- Versions
- 2025.11
No fix published
facturascripts/facturascripts Packagist
- Versions
- 2025.41
No fix published
facturascripts/facturascripts Packagist
- Versions
- 2025.43
No fix published