p PatchFirst

CVE-2025-6948

CVE-2025-6948 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 17.11 before 17.11.6, 18.0 before 18.0.4, and 18.1 before 18.1.2 that, under certain conditions, could have allowed a successful attacker to execute actions on behalf of users by injecting malicious content.

CVSS 8.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.11, < 17.11.6: Affected (semver)
    • ≥ 18.0, < 18.0.4: Affected (semver)
    • ≥ 18.1, < 18.1.2: Affected (semver)

    Update to 17.11.6; Update to 18.0.4; Update to 18.1.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →