CVE-2025-69662
CVE-2025-69662
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database.
CVSS 8.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-geopandas Debian:12
- Versions
- 0.12.2-1
- 0.13.0-1~exp1
- 0.13.2-1
- 0.13.2-1~exp1
- 0.13.2-2
- 0.13.2-3
- 0.14.0-1
- 0.14.1-1
- 0.14.2-1
- 0.14.3-1
- 0.14.3-2
- 0.14.4-1
- 1.0.1-1
- 1.0.1-2
- 1.1.0-1~exp1
- 1.1.1-1
- 1.1.1-1~exp1
- 1.1.1-2
- 1.1.2-1
- 1.1.2-2
- 1.1.3-1
- 1.1.3-2
- 1.1.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-geopandas Debian:13
- Versions
- 1.0.1-2
- 1.1.0-1~exp1
- 1.1.1-1
- 1.1.1-1~exp1
- 1.1.1-2
- 1.1.2-1
- 1.1.2-2
- 1.1.3-1
- 1.1.3-2
- 1.1.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-geopandas Debian:14
- Versions
- 1.0.1-2
- 1.1.0-1~exp1
- 1.1.1-1
- 1.1.1-1~exp1
- 1.1.1-2
- Affected ranges
- ECOSYSTEM: < 1.1.2-1
Update to 1.1.2-1
geopandas PyPI
- Versions
- 0.1.0
- 0.1.0.dev-120828c
- 0.1.0.dev-120d5ee
- 0.1.0.dev-189a35c
- 0.1.0.dev-1edddad
- 0.1.0.dev-2be7de8
- 0.1.0.dev-2d642e0
- 0.1.0.dev-3ebcae0
- 0.1.0.dev-40ec104
- 0.1.0.dev-53f669a
- 0.1.0.dev-6c816f0
- 0.1.0.dev-7788a17
- 0.1.0.dev-8144a45
- 0.1.0.dev-a7b594e
- 0.1.0.dev-a91e8ab
- 0.1.0.dev-abb4137
- 0.1.0.dev-c770a5c
- 0.1.0.dev-fea5c40
- 0.1.1
- 0.10.0
- 0.10.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.12.0
- 0.12.1
- 0.12.2
- 0.13.0
- 0.13.1
- 0.13.2
- 0.14.0
- 0.14.1
- 0.14.2
- 0.14.3
- 0.14.4
- 0.1dev
- 0.2
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.1
- 0.5.0
- 0.5.1
- 0.6.0
- 0.6.0rc1
- 0.6.1
- 0.6.2
- 0.6.3
- 0.7.0
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 1.0.0
- 1.0.0a1
- 1.0.0rc1
- 1.0.1
- 1.1.0
- 1.1.1
- Affected ranges
- ECOSYSTEM: < 1.1.2
Update to 1.1.2
python-geopandas Ubuntu:22.04:LTS
- Versions
- 0.8.2-1
- 0.10.2-1
- Affected ranges
- ECOSYSTEM: < 0.10.2-1ubuntu0.1
Update to 0.10.2-1ubuntu0.1
python-geopandas Ubuntu:24.04:LTS
- Versions
- 0.13.2-3
- 0.14.0-1
- 0.14.1-1
- 0.14.2-1
- 0.14.3-1
- 0.14.3-2
- Affected ranges
- ECOSYSTEM: < 0.14.3-2ubuntu0.1
Update to 0.14.3-2ubuntu0.1
python-geopandas Ubuntu:25.10
- Versions
- 1.0.1-1
- 1.0.1-2
- Affected ranges
- ECOSYSTEM: < 1.0.1-2ubuntu0.1
Update to 1.0.1-2ubuntu0.1