p PatchFirst

CVE-2025-6985

CVE-2025-6985 · XXE Vulnerability in langchain-ai/langchain

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The HTMLSectionSplitter class in langchain-text-splitters version 0.3.8 is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing. This vulnerability arises because the class allows the use of arbitrary XSLT stylesheets, which are parsed using lxml.etree.parse() and lxml.etree.XSLT() without any hardening measures. In lxml versions up to 4.9.x, external entities are resolved by default, allowing attackers to read arbitrary local files or perform outbound HTTP(S) fetches. In lxml versions 5.0 and above, while entity expansion is disabled, the XSLT document() function can still read any URI unless XSLTAccessControl is applied. This vulnerability allows remote attackers to gain read-only access to any file the LangChain process can reach, including sensitive files such as SSH keys, environment files, source code, or cloud metadata. No authentication, special privileges, or user interaction are required, and the issue is exploitable in default deployments that enable custom XSLT.

CVSS 7.5 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • langchain-ai/langchain

    Versions
    • ≥ unspecified, ≤ latest: Affected (custom)

    No fix published

  • langchain-text-splitters PyPI

    Versions
    • 0.0.1
    • 0.0.2
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.2.4
    • 0.3.0
    • 0.3.0.dev0
    • 0.3.0.dev1
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.6rc1
    • 0.3.6rc2
    • 0.3.7
    • 0.3.8
    Affected ranges
    • ECOSYSTEM: < 0.3.9

    Update to 0.3.9

Original sources

Check your server →