p PatchFirst

CVE-2025-7001

CVE-2025-7001 · Insufficient Granularity of Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 15.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed priviledged users to access certain resource_group information through the API which should have been unavailable.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.0, < 18.0.5: Affected (semver)
    • ≥ 18.1, < 18.1.3: Affected (semver)
    • ≥ 18.2, < 18.2.1: Affected (semver)

    Update to 18.0.5; Update to 18.1.3; Update to 18.2.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →