CVE-2025-70103
CVE-2025-70103
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap buffer overflow vulnerability in libjxl 0.12.0 via crafted PBM images to the jxl::extras::DecodeImagePNM function in file lib/extras/dec/pnm.cc.
CVSS 7.3 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jpeg-xl Debian:12
- Versions
- 0.10.3-1
- 0.10.3-2
- 0.10.3-3
- 0.10.3-4
- 0.10.3-5
- 0.10.4-1
- 0.10.4-2
- 0.11.1-1
- 0.11.1-2
- 0.11.1-3
- 0.11.1-4
- 0.11.1-5
- 0.11.1-6
- 0.11.2-0.1
- 0.11.2-0.1~deb13u1
- 0.11.2-0.1~deb13u2
- 0.11.2-1
- 0.11.2-2
- 0.11.2-3
- 0.11.2-3~exp1
- 0.11.2-4
- 0.11.2-5
- 0.11.2-5.1
- 0.7.0-10
- 0.7.0-10+deb12u1
- 0.7.0-10.1
- 0.7.0-10.2
- 0.8.0-1
- 0.8.0~git20221120.4167056-1
- 0.8.0~git20221123.8bf8deb-1
- 0.8.0~git20230102.26a5158-1
- 0.8.0~git20230118.bcacd51-1
- 0.8.0~git20230125.a67e970-1
- 0.8.1-1
- 0.8.1-2
- 0.8.2-1
- 0.8.2-2
- 0.8.2-3
- 0.8.2-4
- 0.9.0~git20230612.38b629f-1
- 0.9.0~git20230612.38b629f-2
- 0.9.0~git20230612.38b629f-3
- 0.9.0~git20230612.38b629f-4
- 0.9.0~git20230623.689da0f-1
- 0.9.0~git20230623.689da0f-2
- 0.9.0~git20230623.689da0f-3
- 0.9.0~git20230623.689da0f-4
- 0.9.2-1
- 0.9.2-10
- 0.9.2-2
- 0.9.2-3
- 0.9.2-4
- 0.9.2-5
- 0.9.2-6
- 0.9.2-7
- 0.9.2-8
- 0.9.2-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jpeg-xl Debian:13
- Versions
- 0.11.1-4
- 0.11.1-5
- 0.11.1-6
- 0.11.2-0.1~deb13u1
- Affected ranges
- ECOSYSTEM: < 0.11.2-0.1~deb13u2
Update to 0.11.2-0.1~deb13u2
jpeg-xl Debian:14
- Versions
- 0.11.1-4
- 0.11.1-5
- 0.11.1-6
- 0.11.2-0.1
- 0.11.2-0.1~deb13u1
- 0.11.2-0.1~deb13u2
- 0.11.2-1
- 0.11.2-2
- 0.11.2-3
- 0.11.2-3~exp1
- 0.11.2-4
- 0.11.2-5
- Affected ranges
- ECOSYSTEM: < 0.11.2-5.1
Update to 0.11.2-5.1
jpeg-xl Ubuntu:25.10
- Versions
- 0.11.1-4
- 0.11.1-6ubuntu1
- 0.11.1-6ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 0.11.1-6ubuntu1.2
Update to 0.11.1-6ubuntu1.2
jpeg-xl Ubuntu:26.04:LTS
- Versions
- 0.11.1-4
- 0.11.1-6ubuntu1
- 0.11.1-6ubuntu3
- 0.11.1-6ubuntu4
- Affected ranges
- ECOSYSTEM: < 0.11.1-6ubuntu4.2
Update to 0.11.1-6ubuntu4.2
Original sources
- https://github.com/libjxl/libjxl/issues/4337
- https://github.com/libjxl/libjxl/pull/4338
- https://github.com/sigdevel/pocs/blob/main/res/libjxl/2025/2
- https://infosec.exchange/@sigdevel/116642233929409910
- http://www.openwall.com/lists/oss-security/2026/05/30/7
- https://nvd.nist.gov/vuln/detail/CVE-2025-70103