CVE-2025-71241
CVE-2025-71241 · SPIP < 4.3.6 Cross-Site Scripting in Private Area
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SPIP before 4.3.6, 4.2.17, and 4.1.20 allows Cross-Site Scripting (XSS) in the private area. The content of the error message displayed by the 'transmettre' API is not properly sanitized, allowing an attacker to inject malicious scripts. This vulnerability is mitigated by the SPIP security screen.
CVSS 4.8 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
spip
- Versions
- ≥ 4.1.0, < 4.1.20: Affected (semver)
- ≥ 4.2.0, < 4.2.17: Affected (semver)
- ≥ 4.3.0, < 4.3.6: Affected (semver)
Update to 4.1.20; Update to 4.2.17; Update to 4.3.6
spip Debian:13
- Affected ranges
- ECOSYSTEM: < 4.3.6+dfsg-1
Update to 4.3.6+dfsg-1
spip Debian:14
- Affected ranges
- ECOSYSTEM: < 4.3.6+dfsg-1
Update to 4.3.6+dfsg-1
spip Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.20-1
- 3.0.21-1
- 3.0.21-1ubuntu1
- 3.0.21-1ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:Pro:18.04:LTS
- Versions
- 3.1.4-3
- 3.1.4-4~deb9u3build0.18.04.1
- 3.1.4-4~deb9u5build0.18.04.1
- 3.1.4-4~deb9u5ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:Pro:20.04:LTS
- Versions
- 3.2.4-1
- 3.2.5-1
- 3.2.7-1
- 3.2.7-1ubuntu0.1
- 3.2.7-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:22.04:LTS
- Versions
- 3.2.11-3
- 3.2.12-1
- 4.0.2-1
- 4.0.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:24.04:LTS
- Versions
- 4.1.11+dfsg-1
- 4.1.12+dfsg-1
- 4.1.13+dfsg-1
- 4.1.15+dfsg-1
- 4.2.9+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published