p PatchFirst

CVE-2025-7715

CVE-2025-7715 · Block Attributes - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-090

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Block Attributes allows Cross-Site Scripting (XSS).This issue affects Block Attributes: from 0.0.0 before 1.1.0, from 2.0.0 before 2.0.1.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • block attributes

    Versions
    • ≥ 0.0.0, < 1.1.0: Affected (semver)
    • ≥ 2.0.0, < 2.0.1: Affected (semver)

    Update to 1.1.0; Update to 2.0.1

  • drupal/block_attributes Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 1.1.0
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.1

    Update to 1.1.0; Update to 2.0.1

Original sources

Check your server →