CVE-2025-7783
CVE-2025-7783 · Usage of unsafe random function in form-data for choosing boundary
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Use of Insufficiently Random Values vulnerability in form-data allows HTTP Parameter Pollution (HPP). This vulnerability is associated with program files lib/form_data.Js. This issue affects form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.
CVSS 9.4 · Critical · EPSS 1.8% · Fix available
- Published
- Updated
Affected products and versions
node-form-data Debian:12
- Versions
- 4.0.0-1
- Affected ranges
- ECOSYSTEM: < 4.0.0-1+deb12u1
Update to 4.0.0-1+deb12u1
node-form-data Debian:13
- Affected ranges
- ECOSYSTEM: < 4.0.1-2
Update to 4.0.1-2
node-form-data Debian:14
- Affected ranges
- ECOSYSTEM: < 4.0.1-2
Update to 4.0.1-2
form-data npm
- Affected ranges
- SEMVER: < 2.5.4
Update to 2.5.4
form-data npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.0.4
Update to 3.0.4
form-data npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.0.4
Update to 4.0.4
node-form-data Ubuntu:Pro:14.04:LTS
- Versions
- 0.1.0-1
- Affected ranges
- ECOSYSTEM: < 0.1.0-1ubuntu0.14.04.1~esm1
Update to 0.1.0-1ubuntu0.14.04.1~esm1
node-form-data Ubuntu:Pro:16.04:LTS
- Versions
- 0.1.0-1
- Affected ranges
- ECOSYSTEM: < 0.1.0-1ubuntu0.16.04.1~esm1
Update to 0.1.0-1ubuntu0.16.04.1~esm1
node-form-data Ubuntu:Pro:18.04:LTS
- Versions
- 0.1.0-1
- Affected ranges
- ECOSYSTEM: < 0.1.0-1ubuntu0.18.04.1~esm1
Update to 0.1.0-1ubuntu0.18.04.1~esm1
node-form-data Ubuntu:Pro:20.04:LTS
- Versions
- 2.3.2-4
- 2.5.1-1
- 3.0.0-2
- Affected ranges
- ECOSYSTEM: < 3.0.0-2ubuntu0.1~esm1
Update to 3.0.0-2ubuntu0.1~esm1
node-form-data Ubuntu:Pro:22.04:LTS
- Versions
- 3.0.0-2
- 3.0.0-4
- 3.0.1-1
- Affected ranges
- ECOSYSTEM: < 3.0.1-1ubuntu0.1~esm1
Update to 3.0.1-1ubuntu0.1~esm1
node-form-data Ubuntu:24.04:LTS
- Versions
- 4.0.0-1
- Affected ranges
- ECOSYSTEM: < 4.0.0-1ubuntu0.1
Update to 4.0.0-1ubuntu0.1