CVE-2025-7885
CVE-2025-7885 · Huashengdun WebSSH Login Page cross site scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability, which was classified as problematic, has been found in Huashengdun WebSSH up to 1.6.2. Affected by this issue is some unknown functionality of the component Login Page. The manipulation of the argument hostname/port leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
CVSS 5.3 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
webssh
- Versions
- 1.6.0: Affected
- 1.6.1: Affected
- 1.6.2: Affected
No fix published
webssh PyPI
- Versions
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.5
- 0.2.6
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.5
- 0.3.9
- 0.4.0
- 0.4.1
- 0.4.6
- 0.5.0
- 0.6.0
- 0.6.1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.9.0
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.1.1
- 1.2.0
- 1.3.0
- 1.4.0
- 1.4.2
- 1.4.3
- 1.4.5
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.2
- Affected ranges
- ECOSYSTEM: < 1.6.3
Update to 1.6.3