CVE-2025-8067
CVE-2025-8067 · Udisks: out-of-bounds read in udisks daemon
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
A flaw was found in the Udisks daemon, where it allows unprivileged users to create loop devices using the D-BUS system. This is achieved via the loop device handler, which handles requests sent through the D-BUS interface. As two of the parameters of this handle, it receives the file descriptor list and index specifying the file where the loop device should be backed. The function itself validates the index value to ensure it isn't bigger than the maximum value allowed. However, it fails to validate the lower bound, allowing the index parameter to be a negative value. Under these circumstances, an attacker can cause the UDisks daemon to crash or perform a local privilege escalation by gaining access to files owned by privileged users.
CVSS 8.5 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
udisks
- Versions
- ≥ 0, < 2.10.2: Affected (semver)
- ≥ 2.10.3, < 2.10.91: Affected (semver)
Update to 2.10.2; Update to 2.10.91
red hat enterprise linux 10
- Versions
- ≥ 0:2.10.90-5.el10_0.1: Not affected (rpm)
No fix published
red hat enterprise linux 7 extended lifecycle support
- Versions
- ≥ 0:2.8.4-1.el7_9.2: Not affected (rpm)
No fix published
red hat enterprise linux 8
- Versions
- ≥ 0:2.9.0-16.el8_10.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.2 advanced update support
- Versions
- ≥ 0:2.8.3-2.el8_2.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.4 advanced mission critical update support
- Versions
- ≥ 0:2.9.0-6.el8_4.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.4 extended update support long-life add-on
- Versions
- ≥ 0:2.9.0-6.el8_4.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 advanced mission critical update support
- Versions
- ≥ 0:2.9.0-9.el8_6.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 telecommunications update service
- Versions
- ≥ 0:2.9.0-9.el8_6.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 update services for sap solutions
- Versions
- ≥ 0:2.9.0-9.el8_6.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.8 telecommunications update service
- Versions
- ≥ 0:2.9.0-13.el8_8.1: Not affected (rpm)
No fix published
red hat enterprise linux 8.8 update services for sap solutions
- Versions
- ≥ 0:2.9.0-13.el8_8.1: Not affected (rpm)
No fix published
red hat enterprise linux 9
- Versions
- ≥ 0:2.9.4-11.el9_6.1: Not affected (rpm)
No fix published
red hat enterprise linux 9.0 update services for sap solutions
- Versions
- ≥ 0:2.9.4-3.el9_0.2: Not affected (rpm)
No fix published
red hat enterprise linux 9.2 update services for sap solutions
- Versions
- ≥ 0:2.9.4-7.el9_2.2: Not affected (rpm)
No fix published
red hat enterprise linux 9.4 extended update support
- Versions
- ≥ 0:2.9.4-10.el9_4.2: Not affected (rpm)
No fix published
red hat enterprise linux 6
No fix published
udisks2 Debian:12
- Versions
- 2.9.4-4
- 2.9.4-4+deb12u1
- Affected ranges
- ECOSYSTEM: < 2.9.4-4+deb12u2
Update to 2.9.4-4+deb12u2
udisks2 Debian:13
- Versions
- 2.10.1-12.1
- Affected ranges
- ECOSYSTEM: < 2.10.1-12.1+deb13u1
Update to 2.10.1-12.1+deb13u1
udisks2 Debian:14
- Versions
- 2.10.1-12.1
- 2.10.90-1
- 2.10.90-2
- 2.10.90-3
- Affected ranges
- ECOSYSTEM: < 2.10.90-3.1
Update to 2.10.90-3.1
udisks2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.1.0-4
- 2.1.1-1
- 2.1.1-1ubuntu1
- 2.1.2-1
- 2.1.3-1
- 2.1.3-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.1.3-1ubuntu0.1+esm1
Update to 2.1.3-1ubuntu0.1+esm1
udisks2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.1.6-2ubuntu1
- 2.1.6-2+git1
- 2.1.7-1
- 2.1.7-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.1.7-1ubuntu1+esm1
Update to 2.1.7-1ubuntu1+esm1
udisks2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.6.5-2ubuntu2
- 2.6.5-2ubuntu3
- 2.7.6-2ubuntu4
- 2.7.6-2ubuntu6
- 2.7.6-3
- 2.7.6-3ubuntu0.1
- 2.7.6-3ubuntu0.2
- 2.7.6-3ubuntu0.2+esm1
- Affected ranges
- ECOSYSTEM: < 2.7.6-3ubuntu0.2+esm2
Update to 2.7.6-3ubuntu0.2+esm2
udisks2 Ubuntu:Pro:20.04:LTS
- Versions
- 2.8.4-1
- 2.8.4-1build1
- 2.8.4-1ubuntu1
- 2.8.4-1ubuntu2
- 2.8.4-1ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: < 2.8.4-1ubuntu2+esm2
Update to 2.8.4-1ubuntu2+esm2
Original sources
- https://access.redhat.com/errata/RHSA-2025:15017
- https://access.redhat.com/errata/RHSA-2025:15018
- https://access.redhat.com/errata/RHSA-2025:15020
- https://access.redhat.com/errata/RHSA-2025:15956
- https://access.redhat.com/errata/RHSA-2025:16021
- https://access.redhat.com/errata/RHSA-2025:16090
- https://access.redhat.com/errata/RHSA-2025:16106
- https://access.redhat.com/errata/RHSA-2025:16121
- https://access.redhat.com/errata/RHSA-2025:16122
- https://access.redhat.com/errata/RHSA-2025:16125
- https://access.redhat.com/errata/RHSA-2025:16130
- https://access.redhat.com/security/cve/CVE-2025-8067
- https://bugzilla.redhat.com/show_bug.cgi?id=2388623
- https://lists.debian.org/debian-lts-announce/2025/08/msg00023.html
- http://www.openwall.com/lists/oss-security/2025/08/28/1
- https://nvd.nist.gov/vuln/detail/CVE-2025-8067