p PatchFirst

CVE-2025-8267

CVE-2025-8267

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP address ranges. Specifically, the package fails to classify the reserved IP address space 224.0.0.0/4 (Multicast) as invalid. This oversight allows attackers to craft requests targeting these multicast addresses.

CVSS 8.8 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • ssrfcheck

    Versions
    • ≥ 0, < 1.2.0: Affected (semver)

    Update to 1.2.0

  • ssrfcheck npm

    Affected ranges
    • SEMVER: < 1.2.0

    Update to 1.2.0

Original sources

Check your server →