p PatchFirst

CVE-2025-8405

CVE-2025-8405 · Improper Encoding or Escaping of Output in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated a security issue in GitLab CE/EE affecting all versions from 17.1 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to perform unauthorized actions on behalf of other users by injecting malicious HTML into vulnerability code flow displays.

CVSS 7.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.1, < 18.4.6: Affected (semver)
    • ≥ 18.5, < 18.5.4: Affected (semver)
    • ≥ 18.6, < 18.6.2: Affected (semver)

    Update to 18.4.6; Update to 18.5.4; Update to 18.6.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →