CVE-2025-8678
CVE-2025-8678 · WP Crontrol - 1.17.0 - 1.19.1 - Authenticated (Administrator+) Blind Server-Side Request Forgery
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
CVSS 5.9 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
wp crontrol
- Versions
- ≥ 1.17.0, ≤ 1.19.1: Affected (semver)
No fix published
johnbillion/wp-crontrol Packagist
- Versions
- 1.17.0
- 1.17.1
- 1.18.0
- 1.19.0
- 1.19.1
- Affected ranges
- ECOSYSTEM: ≥ 1.17.0, < 1.19.2
Update to 1.19.2