p PatchFirst

CVE-2025-9141

CVE-2025-9141 · vLLM has remote code execution vulnerability in the tool call parser for Qwen3-Coder

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Summary An unsafe deserialization vulnerability allows any authenticated user to execute arbitrary code on the server if they are able to get the model to pass the code as an argument to a tool call. ### Details vLLM's [Qwen3 Coder tool parser](https://github.com/vllm-project/vllm/blob/main/vllm/entrypoints/openai/tool_parsers/qwen3coder_tool_parser.py) contains a code execution path that uses Python's `eval()` function to parse tool call parameters. This occurs during the parameter conversion process when the parser attempts to handle unknown data types. This code path is reached when: 1. Tool calling is enabled (`--enable-auto-tool-choice`) 2. The qwen3_coder parser is specified (`--tool-call-parser qwen3_coder`) 3. The parameter type is not explicitly defined or recognized ### Impact Remote Code Execution via Python's `eval()` function.

CVSS 8.8 · High · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm PyPI

    Versions
    • 0.10.0
    • 0.10.1
    Affected ranges
    • ECOSYSTEM: ≥ 0.10.0, < 0.10.1.1

    Update to 0.10.1.1

Original sources

Check your server →