CVE-2025-9550
CVE-2025-9550 · Facets - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-100
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Facets allows Cross-Site Scripting (XSS).This issue affects Facets: from 0.0.0 before 2.0.10, from 3.0.0 before 3.0.1.
CVSS 6.1 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
facets
- Versions
- ≥ 0.0.0, < 2.0.10: Affected (semver)
- ≥ 3.0.0, < 3.0.1: Affected (semver)
Update to 2.0.10; Update to 3.0.1
drupal/facets Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 2.0.10
- ECOSYSTEM: ≥ 3.0.0, < 3.0.1
Update to 2.0.10; Update to 3.0.1