p PatchFirst

CVE-2025-9551

CVE-2025-9551 · Protected Pages - Moderately critical - Access bypass - SA-CONTRIB-2025-101

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Protected Pages allows Brute Force.This issue affects Protected Pages: from 0.0.0 before 1.8.0, from 7.X-1.0 before 7.X-2.5.

CVSS 6.5 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • protected pages

    Versions
    • ≥ 0.0.0, < 1.8.0: Affected (semver)
    • ≥ 7.x-1.0, < 7.x-2.5: Affected (custom)

    Update to 1.8.0; Update to 7.x-2.5

  • drupal/protected_pages Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 1.8.0

    Update to 1.8.0

Original sources

Check your server →