CVE-2025-9910
CVE-2025-9910
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package jsondiffpatch before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin. An attacker can inject malicious scripts into HTML payloads that may lead to code execution if untrusted payloads were used as source for the diff, and the result renderer using the built-in html formatter on a private website.
CVSS 2.3 · Low · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
jsondiffpatch
- Versions
- ≥ 0, < 0.7.2: Affected (semver)
Update to 0.7.2
org.webjars.npm:jsondiffpatch
- Versions
- ≥ 0: Affected (semver)
No fix published
org.webjars.bower:jsondiffpatch
- Versions
- ≥ 0: Affected (semver)
No fix published
jsondiffpatch npm
- Affected ranges
- SEMVER: < 0.7.2
Update to 0.7.2
Original sources
- https://security.snyk.io/vuln/SNYK-JS-JSONDIFFPATCH-10369031
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-12549276
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-12549277
- https://github.com/benjamine/jsondiffpatch/commit/0e374b5dd8d7879b329a9fc18affbd46ad50dd14
- https://github.com/benjamine/jsondiffpatch/issues/383
- https://benjamine.github.io/jsondiffpatch/index.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-9910