p PatchFirst

CVE-2025-9957

CVE-2025-9957 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that under certain conditions could have allowed an authenticated user with project owner permissions to bypass group fork prevention settings due to improper authorization checks.

CVSS 2.7 · Low · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 11.2, < 18.9.6: Affected (semver)
    • ≥ 18.10, < 18.10.4: Affected (semver)
    • ≥ 18.11, < 18.11.1: Affected (semver)

    Update to 18.10.4; Update to 18.11.1; Update to 18.9.6

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →