CVE-2026-0755
CVE-2026-0755 · gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of gemini-mcp-tool. Authentication is not required to exploit this vulnerability. The specific flaw exists within the implementation of the execAsync method. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-27783.
CVSS 9.8 · Critical · EPSS 3.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
gemini-mcp-tool
- Versions
- 1.1.2: Affected
No fix published
gemini-mcp-tool npm
- Affected ranges
- SEMVER: ≥ 1.1.2, < 1.1.6
Update to 1.1.6