p PatchFirst

CVE-2026-0958

CVE-2026-0958 · Interpretation Conflict in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.4 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that could have allowed an unauthenticated user to cause denial of service through memory or CPU exhaustion by bypassing JSON validation middleware limits.

CVSS 7.5 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 18.4, < 18.6.6: Affected (semver)
    • ≥ 18.7, < 18.7.4: Affected (semver)
    • ≥ 18.8, < 18.8.4: Affected (semver)

    Update to 18.6.6; Update to 18.7.4; Update to 18.8.4

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →