CVE-2026-100310
CVE-2026-100310 · GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.
CVSS 7.3 · High · EPSS 0.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libextractor
- Versions
- ≥ 0, < 1.16: Affected (custom)
Update to 1.16
libextractor Debian:12
- Versions
- 1:1.11-7
- 1:1.11-8
- 1:1.13-1
- 1:1.13-10
- 1:1.13-2
- 1:1.13-3
- 1:1.13-4
- 1:1.13-4+loong64
- 1:1.13-5
- 1:1.13-6
- 1:1.13-7
- 1:1.13-8
- 1:1.13-9
- 1:1.17-1
- 1:1.19-1
- 1:1.19-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Debian:13
- Versions
- 1:1.13-10
- 1:1.13-8
- 1:1.13-9
- 1:1.17-1
- 1:1.19-1
- 1:1.19-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Debian:14
- Versions
- 1:1.13-10
- 1:1.13-8
- 1:1.13-9
- Affected ranges
- ECOSYSTEM: < 1:1.17-1
Update to 1:1.17-1
libextractor Ubuntu:Pro:14.04:LTS
- Versions
- 1:1.1-1ubuntu1
- 1:1.2-1ubuntu1
- 1:1.3-1
- 1:1.3-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:16.04:LTS
- Versions
- 1:1.3-2build1
- 1:1.3-2ubuntu1
- 1:1.3-3
- 1:1.3-4+deb9u3build0.16.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:18.04:LTS
- Versions
- 1:1.3-4build3
- 1:1.6-1
- 1:1.6-1build1
- 1:1.6-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:20.04:LTS
- Versions
- 1:1.9-2
- 1:1.9-2ubuntu1
- 1:1.9-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:22.04:LTS
- Versions
- 1:1.11-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:24.04:LTS
- Versions
- 1:1.11-8
- 1:1.13-3
- 1:1.13-3build2
- 1:1.13-3build3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:26.10
- Versions
- 1:1.13-9
- 1:1.13-10
- 1:1.19-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libextractor Ubuntu:26.04:LTS
- Versions
- 1:1.13-8build1
- 1:1.13-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/Haitam-lazaar/libextractor-privesc
- https://git.gnunet.org/gnunet/libextractor/commit/6edfa653c048800e24a17f7e8cc2bb42659b8d01.html
- https://ftp.gnu.org/gnu/libextractor/
- https://www.gnu.org/software/libextractor/
- https://www.vulncheck.com/advisories/gnu-libextractor-before-1.16-privilege-escalation-via-libextractor-prefix
- http://www.openwall.com/lists/oss-security/2026/09/25/25
- https://nvd.nist.gov/vuln/detail/CVE-2026-100310