p PatchFirst

CVE-2026-100840

CVE-2026-100840 · MONAI through 1.6.0 Remote Code Execution via bundle configuration

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().

CVSS 8.5 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • monai

    Versions
    • ≥ 0, ≤ 1.6.0: Affected (semver)

    No fix published

  • monai PyPI

    Versions
    • 0.0.1
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.6.0
    • 0.7.0
    • 0.8.0
    • 0.8.1
    • 0.9.0
    • 0.9.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.2rc1
    • 1.3.3rc1
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc10
    • 1.4.0rc11
    • 1.4.0rc12
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.0rc7
    • 1.4.0rc8
    • 1.4.0rc9
    • 1.4.1rc1
    • 1.5.0
    • 1.5.0rc1
    • 1.5.1
    • 1.5.2
    • 1.5.2rc1
    • 1.6.0
    Affected ranges
    • ECOSYSTEM: < 1.6.1rc0

    Update to 1.6.1rc0

Original sources

Check your server →