p PatchFirst

CVE-2026-100844

CVE-2026-100844 · MONAI before 1.6.0 OS Command Injection via dataset_name_or_id

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MONAI before 1.6.0 is vulnerable to OS command injection in the nnUNetV2Runner component (monai.apps.nnunet.nnunetv2_runner). User-controlled values taken from the YAML configuration file (notably dataset_name_or_id) and from CLI/kwargs arguments are concatenated into a command string without quoting or validation and then passed to subprocess with shell=True, so shell metacharacters (e.g., ';' on Linux, '&' on Windows) are interpreted. If a victim loads and processes a crafted configuration file — for example by instantiating nnUNetV2Runner with the malicious YAML and invoking a training/validation job such as train_single_model() — arbitrary commands are executed with the privileges of the user running the job.

CVSS 8.6 · High · EPSS 0.9% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • monai

    Versions
    • ≥ 0, < 1.6.0: Affected (semver)
    • 1.6.0: Not affected (semver)

    Update to 1.6.0

  • monai PyPI

    Versions
    • 0.0.1
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.6.0
    • 0.7.0
    • 0.8.0
    • 0.8.1
    • 0.9.0
    • 0.9.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.2rc1
    • 1.3.3rc1
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc10
    • 1.4.0rc11
    • 1.4.0rc12
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.0rc7
    • 1.4.0rc8
    • 1.4.0rc9
    • 1.4.1rc1
    • 1.5.0
    • 1.5.0rc1
    • 1.5.1
    • 1.5.2
    • 1.5.2rc1
    Affected ranges
    • ECOSYSTEM: < 1.6.0

    Update to 1.6.0

Original sources

Check your server →