CVE-2026-102827
CVE-2026-102827 · simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.
CVSS 8.1 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
git-js
- Versions
- < 4.0.0: Affected
No fix published
simple-git npm
- Affected ranges
- SEMVER: < 4.0.0
Update to 4.0.0
Original sources
- https://github.com/steveukx/git-js/security/advisories/GHSA-858h-whjf-mvg5
- https://github.com/steveukx/git-js/pull/1193
- https://github.com/steveukx/git-js/commit/98864c678444d9336357c844efa4fd5a7984c0d7
- https://github.com/steveukx/git-js/releases/tag/[email protected]
- https://nvd.nist.gov/vuln/detail/CVE-2026-102827