p PatchFirst

CVE-2026-10291

CVE-2026-10291 · Enderfga claw-orchestrator Session Grep Endpoint embedded-server.ts validateRegex redos

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A security vulnerability has been detected in Enderfga claw-orchestrator up to 3.7.0. The impacted element is the function validateRegex of the file claw-orchestrator/src/embedded-server.ts of the component Session Grep Endpoint. The manipulation of the argument body.pattern leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 3.7.1 is sufficient to resolve this issue. The identifier of the patch is 3f970a974c65a94555c25af9f2796f11315e4584. It is recommended to upgrade the affected component.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • claw-orchestrator

    Versions
    • 3.0: Affected
    • 3.1: Affected
    • 3.2: Affected
    • 3.3: Affected
    • 3.4: Affected
    • 3.5: Affected
    • 3.6: Affected
    • 3.7.0: Affected
    • 3.7.1: Not affected

    Update to 3.7.1

  • @enderfga/claw-orchestrator npm

    Affected ranges
    • SEMVER: < 3.7.1

    Update to 3.7.1

Original sources

Check your server →