p PatchFirst

CVE-2026-104417

CVE-2026-104417 · Ghost 1.20.0 before 6.64.0 Path Traversal via Locale Setting

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ghost from 1.20.0 before 6.64.0 contains a path traversal vulnerability in theme translation file loading that allows authenticated administrators to read JSON files outside the active theme directory. Attackers can manipulate the locale setting to load JSON files elsewhere on the server, exposing server configuration secrets.

CVSS 6.9 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • ghost

    Versions
    • ≥ 1.20.0, < 6.64.0: Affected (semver)
    • 6.64.0: Not affected (semver)

    Update to 6.64.0

  • ghost npm

    Affected ranges
    • SEMVER: ≥ 1.20.0, < 6.64.0

    Update to 6.64.0

Original sources

Check your server →