CVE-2026-104592
CVE-2026-104592
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libosmocore through 1.14.1 contains an out-of-bounds read in the CBSP WRITE-REPLACE decoder in src/gsm/cbsp.c. This allows a remote attacker to cause a denial of service.
CVSS 6.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libosmocore Debian:12
- Versions
- 1.10.0-1
- 1.10.0-2
- 1.11.0-1
- 1.11.0-2
- 1.14.0-1
- 1.14.2-1
- 1.7.0-3
- 1.7.0-3.1
- 1.7.0-3.1~exp1
- 1.9.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Debian:13
- Versions
- 1.11.0-2
- 1.14.0-1
- 1.14.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Debian:14
- Versions
- 1.11.0-2
- 1.14.0-1
- Affected ranges
- ECOSYSTEM: < 1.14.2-1
Update to 1.14.2-1
libosmocore Ubuntu:16.04:LTS
- Versions
- 0.9.0-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:18.04:LTS
- Versions
- 0.9.0-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:20.04:LTS
- Versions
- 0.12.1-3
- 0.12.1-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:22.04:LTS
- Versions
- 1.4.2-3
- 1.6.0-3
- 1.6.0-3build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:24.04:LTS
- Versions
- 1.7.0-3
- 1.7.0-3.1build1
- 1.7.0-3.1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:26.10
- Versions
- 1.11.0-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libosmocore Ubuntu:26.04:LTS
- Versions
- 1.11.0-2
- 1.11.0-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published