p PatchFirst

CVE-2026-104948

CVE-2026-104948

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WarehousePG (WHPG) 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability (CWE-862) in the built-in cluster expansion functions gp_expand_lock_catalog() and gp_expand_bump_version(). Any authenticated database role can run them, and neither checks privileges. A low-privileged user can call gp_expand_lock_catalog() inside an open transaction to block all catalog changes across the cluster for every user, superusers included, until that transaction ends, which in practice requires a superuser to terminate the session. Blocked changes include DDL, temporary table creation, GRANT and CREATE ROLE. The same user can call gp_expand_bump_version() repeatedly. Each call disconnects sessions that hold temporary tables, with a FATAL error on their next catalog change, and makes every other session rebuild its segment connections.

CVSS 7.1 · High · EPSS 0.2% · Fix available

Published
Updated

Affected products and versions

  • warehousepg

    Versions
    • ≥ 6.27.1, < 6.27.7: Affected (semver)
    • ≥ 7.2.1, < 7.6.1: Affected (semver)

    Update to 6.27.7; Update to 7.6.1

Original sources

Check your server →